0

Can I control the button appearance for devices in Claro (DK one)

605 0 2
Posted   7 months ago
  ●   Edited   7 months ago

Hi Guys,

Can I control the button appearance for devices in Claro (DK one), I have given the play button in each page only when the user click the button the content/element and audio play. as I have off the auto play for audio. 

But by client want the button should appear only in iPad, so that in iPad user should tap the button to play the page content. In PC and Laptop it should play automatically.

Can you please suggest me to achieve this.

Thank You, 
Regards,
Ravi S

 

 

Comments

( 0 )

Answers  ( 2 )

1
avatar Chris Van Wingerden   |    
Posted   7 months ago

We do have some functionality built-in that might address what you need to do. Basically, if you have narration audio set to autoplay, then if for some reason it can't autoplay we show a built-in button that gives the learner the ability to start the audio. We did this in response to the way that most browsers have moved to not allowing autoplay of media like audio and video, especially on mobile devices.

Here's a link to the article with more information on that built-in feature

You can also set the device type as a trigger for most actions. 

So you could set up a button on the page to play the audio file when clicked (I won't list those steps here), but only show that button if the learner is on a mobile device.

  1. Select the Interact tab
  2. Select Triggers
  3. Select Current Page >> is Loaded
  4. On the panel that opens, select Show
  5. Select Next
  6. On the panel that opens to the right of the stage, select the button, then on the Triggers: drop down list, select When Viewed On...
  7. Now, you'll see a list of device options. If you only want the audio to autoplay on mobile devices, just select the Smartphone and Tablet checkboxes.
  8. Select Apply.   

Hope this helps!

Comments

( 0 )
0
avatar ravis   |    
Posted   7 months ago

Thank You Very much Chris for you response, 

When I do this, I am facing few more issues:

a. 1st page audio and content loads fine when I move to next page the current page audio plays double (in Edge) 

b. audio and content does not load initially but when I use play button from player on top only audio plays but content does not load (IE 11, Chrome, and iOS)

c. When i come back to Previous page audio plays double.

 

Comments

( 1 )
0
7 months ago     Chris Van Wingerden     683   |   6  

Ravi, sounds like some detective work is needed. I'll connect you with our support team to follow up.